New IT forum
24 October 2021, 04:02:30 pm *
Welcome, %1$s. Please login or register.

: CubieBoard 2 and Cubietruck both now in stock.
 
Pages: [1]

Author Topic: Problems with repositories?  (Read 25161 times)

bkv

  • Newbie
  • *
  • Posts: 15
Problems with repositories?
« on: 09 July 2011, 06:21:48 pm »

Hi
I got a lot of error messages when I ran an apt-get update. See log below. What does this mean?
Regards,
Bjorn



sudo apt-get update
Ign http://ports.ubuntu.com jaunty Release.gpg
Ign http://ports.ubuntu.com jaunty-updates Release.gpg
Ign http://ports.ubuntu.com jaunty-security Release.gpg
Ign http://ports.ubuntu.com jaunty Release
Ign http://ports.ubuntu.com jaunty-updates Release
Ign http://ports.ubuntu.com jaunty-security Release
Ign http://ports.ubuntu.com jaunty/main Packages
Ign http://ports.ubuntu.com jaunty/restricted Packages
Ign http://ports.ubuntu.com jaunty/universe Packages
Ign http://ports.ubuntu.com jaunty/multiverse Packages
Ign http://ports.ubuntu.com jaunty-updates/main Packages
Ign http://ports.ubuntu.com jaunty-updates/restricted Packages
Ign http://ports.ubuntu.com jaunty-updates/universe Packages
Ign http://ports.ubuntu.com jaunty-updates/multiverse Packages
Ign http://ports.ubuntu.com jaunty-security/main Packages
Ign http://ports.ubuntu.com jaunty-security/restricted Packages
Ign http://ports.ubuntu.com jaunty-security/universe Packages
Ign http://ports.ubuntu.com jaunty-security/multiverse Packages
Ign http://ports.ubuntu.com jaunty/main Packages
Ign http://ports.ubuntu.com jaunty/restricted Packages
Ign http://ports.ubuntu.com jaunty/universe Packages
Ign http://ports.ubuntu.com jaunty/multiverse Packages
Ign http://ports.ubuntu.com jaunty-updates/main Packages
Ign http://ports.ubuntu.com jaunty-updates/restricted Packages
Ign http://ports.ubuntu.com jaunty-updates/universe Packages
Ign http://ports.ubuntu.com jaunty-updates/multiverse Packages
Ign http://ports.ubuntu.com jaunty-security/main Packages
Ign http://ports.ubuntu.com jaunty-security/restricted Packages
Ign http://ports.ubuntu.com jaunty-security/universe Packages
Ign http://ports.ubuntu.com jaunty-security/multiverse Packages
Err http://ports.ubuntu.com jaunty/main Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty/restricted Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty/universe Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty/multiverse Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-updates/main Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-updates/restricted Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-updates/universe Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-updates/multiverse Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-security/main Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-security/restricted Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-security/universe Packages
  404 Not Found
Err http://ports.ubuntu.com jaunty-security/multiverse Packages
  404 Not Found
W: Failed to fetch http://ports.ubuntu.com/dists/jaunty/main/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty/restricted/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty/universe/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty/multiverse/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-updates/main/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-updates/restricted/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-updates/universe/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-updates/multiverse/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-security/main/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-security/restricted/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-security/universe/binary-armel/Packages  404 Not Found

W: Failed to fetch http://ports.ubuntu.com/dists/jaunty-security/multiverse/binary-armel/Packages  404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.
Logged

bkv

  • Newbie
  • *
  • Posts: 15
Re: Problems with repositories?
« Reply #2 on: 09 July 2011, 07:18:11 pm »

See here:

http://www.newit.co.uk/forum/index.php/topic,44.0.html

And here:

http://plugcomputer.org/plugwiki/index.php/New_Plugger_How_To#Fixing_the_existing_Ubuntu_install


Sorry Marcus, but I don't quite see how that helps me. I found nothing in the first link that I could relate to may problem. From the second linke I learned that I should add these lines to rc.local:
chmod 1777 /tmp /var/tmp
mkdir -p /var/cache/apt/archives/partial

I did that and reran it. What more should I do?

-Bjorn
Logged

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: Problems with repositories?
« Reply #3 on: 09 July 2011, 08:47:05 pm »

I provided the links so that you can fix networking. This is unlikely to be an apt-get issue; it is most likely a networking issue. There are fixes required of the ex-factory sheevaplug.

So:

  • Is networking working?
  • does ports.ubuntu.com  resolve?
Logged

bkv

  • Newbie
  • *
  • Posts: 15
Re: Problems with repositories?
« Reply #4 on: 09 July 2011, 08:55:36 pm »

I provided the links so that you can fix networking. This is unlikely to be an apt-get issue; it is most likely a networking issue. There are fixes required of the ex-factory sheevaplug.

So:

  • Is networking working?
  • does ports.ubuntu.com  resolve?

Networking seems fine. When I ping ports.ubuntu.com I get:
64 bytes from wahoo.canonical.com (91.189.92.175): icmp_seq=7 ttl=51 time=42.

-Bjorn
Logged

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: Problems with repositories?
« Reply #5 on: 09 July 2011, 09:58:18 pm »

Turns out I get the same as you reported in your first post :-) Sorry for the off-road response to your first post; it's just that basic networking problems are something that we see from time to time from those that didn't fix the ex-factory Sheevaplug settings, or have some fundamental local network problems.

I don't know if these errors are a temporary blip, or something that is a consequence of the age / lack of support for jaunty. I see similar occasional reports going back a couple of years, via google, so hopefully it's temporary.
Logged

jmerckx

  • Newbie
  • *
  • Posts: 1
Re: Problems with repositories?
« Reply #6 on: 11 July 2011, 10:01:45 am »

Try http://old-releases.ubuntu.com/ubuntu/ instead of http://ports.ubuntu.com/ in your /etc/apt/sources.list
Logged

OMcGovern

  • Newbie
  • *
  • Posts: 4
Re: Problems with repositories?
« Reply #7 on: 11 July 2011, 10:49:01 pm »

Thanks jmerckx, that worked on my DreamPlug.
Logged

bkv

  • Newbie
  • *
  • Posts: 15
Re: Problems with repositories?
« Reply #8 on: 12 July 2011, 06:58:59 pm »

Great! It worked for me too.
-Bjorn
Logged

NewIT_Marcus

  • Hero Member
  • *****
  • Posts: 960
Re: Problems with repositories?
« Reply #9 on: 13 July 2011, 07:27:30 am »

Try http://old-releases.ubuntu.com/ubuntu/ instead of http://ports.ubuntu.com/ in your /etc/apt/sources.list


Thank you very much for providing the fix.
Logged

Pepo72

  • Newbie
  • *
  • Posts: 1
Logged

Percival P Plugsley

  • Newbie
  • *
  • Posts: 16
Re: Problems with repositories?
« Reply #11 on: 07 November 2011, 10:44:55 pm »

old-releases didn't work for me when I wanted to install smbfs tonight but I did find the .deb via Launchpad:
https://launchpad.net/ubuntu/jaunty/armel
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!