New IT forum
02 September 2015, 02:21:55 am *
Welcome, %1$s. Please login or register.
Did you miss your activation email?

: GertDuino now in stock.
 
Pages: [1]

Author Topic: SheevaPlug UBIFS - Unable to read "/boot/uImage" from mmc 0:1  (Read 1967 times)

atc

  • Newbie
  • *
  • Posts: 5
SheevaPlug UBIFS - Unable to read "/boot/uImage" from mmc 0:1
« on: 22 October 2011, 01:28:30 pm »

Hi all,

I want to move my UBIFS booting from NAND to SD Card. I bought a 16GB SDHC card, formatted and copied the NAND system to the SD as-per the instructions on this page, but I'm unfortunately presented with the following errors when typing "boot" at the Marvell prompt:

Code: [Select]
CRC:                0x00, b0 = 0

** Unable to read "/boot/uImage" from mmc 0:1 **
## Booting image at 00800000 ...
Bad Magic Number

NAND read: device 0 offset 0x100000, size 0x400000

Reading data from 0x4ff800 -- 100% complete.
 4194304 bytes read: OK
## Booting image at 00800000 ...
   Image Name:   Linux-2.6.36
   Created:      2010-12-05  16:26:56 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2948072 Bytes =  2.8 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

The SD is formatted as ext2:

Code: [Select]
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
tmpfs        tmpfs      256644         0    256644   0% /lib/init/rw
udev         tmpfs       10240       116     10124   2% /dev
tmpfs        tmpfs      256644         4    256640   1% /dev/shm
rootfs      rootfs      472140    353440    113864  76% /
/dev/mmcblk0p1
              ext2    15932240    606068  14516860   5% /mnt/sd

What have I done wrong? Can anyone help?

I did search but there was no solution that I can see...

Thanks in advance!
Logged

atc

  • Newbie
  • *
  • Posts: 5
Re: SheevaPlug UBIFS - Unable to read "/boot/uImage" from mmc 0:1
« Reply #1 on: 08 November 2011, 07:08:19 pm »

Problem was user error. I hadn't read the instructions properly which said to put the setenv variables on the Marvell uBoot console "as one long input line"; I was in fact doing them on their own lines.
Logged
Pages: [1]
 
 

Powered by MySQL Powered by PHP SMF 2.0.10 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!